読者です 読者をやめる 読者になる 読者になる

元フリーエンジニアライフ

Ruby on Rails とか MovableType とかAWSやってるフリーランスウェブエンジニアの記録でした。現在は法人成りしてIT社長。

AmazonLinux 2015.09 に Qt5 WebKit をインストール

まとめ

sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/NetworkManager-glib-0.8.1-99.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/libsoup-2.34.3-3.el6_6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/gnome-keyring-2.28.2-8.el6_3.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/GConf2-2.28.0-6.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ORBit2-2.14.17-5.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/polkit-0.96-11.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ConsoleKit-0.4.1-3.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ConsoleKit-libs-0.4.1-3.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/polkit-0.96-11.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ConsoleKit-0.4.1-3.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/polkit-0.96-11.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/eggdbus-0.6-3.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/glib-networking-2.28.6.1-2.2.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/gtk2-2.24.23-6.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/atk-1.30.0-1.el6.x86_64.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/hicolor-icon-theme-0.11-1.1.el6.noarch.rpm \
ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/gdk-pixbuf2-2.24.1-5.el6.x86_64.rpm 
sudo yum install qt5-qtwebkit-devel

はじめに

yumqt5-qtwebkit-develがあったので簡単かと思いきや・・・

$ sudo yum install qt5-qtwebkit-devel
(snip)
--> Finished Dependency Resolution
Error: Package: qt5-qtlocation-5.5.1-2.el6.x86_64 (epel)
           Requires: libgeoclue.so.0()(64bit)
Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel)
           Requires: libgtk-x11-2.0.so.0()(64bit)
Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel)
           Requires: libgdk-x11-2.0.so.0()(64bit)
Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel)
           Requires: libatk-1.0.so.0()(64bit)
Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel)
           Requires: libgdk_pixbuf-2.0.so.0()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Amazon Linux AMI yum リポジトリには足りないパッケージがあるようで、うまくいきませんでした。

依存パッケージのインストール

依存関係を1つずつクリアしていきます。

仕方がないのでCentOS6から引っ張ってくることにしました。正直よくないので、いずれ対応するといいのですが。

Error: Package: qt5-qtlocation-5.5.1-2.el6.x86_64 (epel) Requires: libgeoclue.so.0()(64bit)

sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64.rpm
Error: Package: geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64 (/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64)
           Requires: libnm-glib.so.2()(64bit)
Error: Package: geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64 (/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64)
           Requires: libsoup-gnome-2.4.so.1()(64bit)
Error: Package: geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64 (/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64)
           Requires: libgconf-2.so.4()(64bit)

再帰的に依存を解決していきます。。。

Error: Package: geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64 (/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64) Requires: libnm-glib.so.2()(64bit)

sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/NetworkManager-glib-0.8.1-99.el6.x86_64.rpm

Error: Package: geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64 (/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64) Requires: libsoup-gnome-2.4.so.1()(64bit)

sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/libsoup-2.34.3-3.el6_6.x86_64.rpm
Error: Package: libsoup-2.34.3-3.el6_6.x86_64 (/libsoup-2.34.3-3.el6_6.x86_64)
           Requires: libgnome-keyring.so.0()(64bit)
Error: Package: libsoup-2.34.3-3.el6_6.x86_64 (/libsoup-2.34.3-3.el6_6.x86_64)
           Requires: glib-networking >= 2.27.90
Error: Package: libsoup-2.34.3-3.el6_6.x86_64 (/libsoup-2.34.3-3.el6_6.x86_64) Requires: libgnome-keyring.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/gnome-keyring-2.28.2-8.el6_3.x86_64.rpm
Error: Package: gnome-keyring-2.28.2-8.el6_3.x86_64 (/gnome-keyring-2.28.2-8.el6_3.x86_64)
           Requires: libgconf-2.so.4()(64bit)
Error: Package: gnome-keyring-2.28.2-8.el6_3.x86_64 (/gnome-keyring-2.28.2-8.el6_3.x86_64)
           Requires: GConf2
Error: Package: gnome-keyring-2.28.2-8.el6_3.x86_64 (/gnome-keyring-2.28.2-8.el6_3.x86_64) Requires: libgconf-2.so.4()(64bit) / Error: Package: gnome-keyring-2.28.2-8.el6_3.x86_64 (/gnome-keyring-2.28.2-8.el6_3.x86_64) Requires: GConf2
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/GConf2-2.28.0-6.el6.x86_64.rpm
# Error: Package: GConf2-2.28.0-6.el6.x86_64 (/GConf2-2.28.0-6.el6.x86_64) Requires: libORBit-2.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ORBit2-2.14.17-5.el6.x86_64.rpm
# Error: Package: GConf2-2.28.0-6.el6.x86_64 (/GConf2-2.28.0-6.el6.x86_64) Requires: libpolkit-gobject-1.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/polkit-0.96-11.el6.x86_64.rpm
Error: Package: polkit-0.96-11.el6.x86_64 (/polkit-0.96-11.el6.x86_64) Requires: ConsoleKit
sudo yum install  ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ConsoleKit-0.4.1-3.el6.x86_64.rpm
# Error: Package: ConsoleKit-0.4.1-3.el6.x86_64 (/ConsoleKit-0.4.1-3.el6.x86_64) Requires: libck-connector.so.0()(64bit)
sudo yum install sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ConsoleKit-libs-0.4.1-3.el6.x86_64.rpm
# Error: Package: ConsoleKit-0.4.1-3.el6.x86_64 (/ConsoleKit-0.4.1-3.el6.x86_64) Requires: libpolkit-gobject-1.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/polkit-0.96-11.el6.x86_64.rpm
## Error: Package: polkit-0.96-11.el6.x86_64 (/polkit-0.96-11.el6.x86_64) Requires: ConsoleKit
sudo yum install  ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/ConsoleKit-0.4.1-3.el6.x86_64.rpm ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/polkit-0.96-11.el6.x86_64.rpm
Error: Package: polkit-0.96-11.el6.x86_64 (/polkit-0.96-11.el6.x86_64) Requires: libeggdbus-1.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/eggdbus-0.6-3.el6.x86_64.rpm
Error: Package: libsoup-2.34.3-3.el6_6.x86_64 (/libsoup-2.34.3-3.el6_6.x86_64) Requires: glib-networking >= 2.27.90
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/glib-networking-2.28.6.1-2.2.el6.x86_64.rpm

Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel) Requires: libgtk-x11-2.0.so.0()(64bit) / Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel) Requires: libgdk-x11-2.0.so.0()(64bit)

sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/gtk2-2.24.23-6.el6.x86_64.rpm
Error: Package: gtk2-2.24.23-6.el6.x86_64 (/gtk2-2.24.23-6.el6.x86_64)
           Requires: atk >= 1.29.4-2
Error: Package: gtk2-2.24.23-6.el6.x86_64 (/gtk2-2.24.23-6.el6.x86_64)
           Requires: hicolor-icon-theme
Error: Package: gtk2-2.24.23-6.el6.x86_64 (/gtk2-2.24.23-6.el6.x86_64)
           Requires: libatk-1.0.so.0()(64bit)
Error: Package: gtk2-2.24.23-6.el6.x86_64 (/gtk2-2.24.23-6.el6.x86_64)
           Requires: libgdk_pixbuf-2.0.so.0()(64bit)
Requires: atk >= 1.29.4-2 / Requires: libatk-1.0.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/atk-1.30.0-1.el6.x86_64.rpm
Requires: hicolor-icon-theme
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/hicolor-icon-theme-0.11-1.1.el6.noarch.rpm
Requires: libgdk_pixbuf-2.0.so.0()(64bit)
sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/gdk-pixbuf2-2.24.1-5.el6.x86_64.rpm

Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel) Requires: libatk-1.0.so.0()(64bit)

これまでの手順でインストール済み

Error: Package: qt5-qtbase-gui-5.5.1-11.el6.x86_64 (epel) Requires: libgdk_pixbuf-2.0.so.0()(64bit)

これまでの手順でインストール済み

yum install qt5-qtwebkit-devel 再び

sudo yum install qt5-qtwebkit-devel
Loaded plugins: priorities, upgrade-helper
944 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package qt5-qtwebkit-devel.x86_64 0:5.5.1-3.el6 will be installed
--> Processing Dependency: qt5-qtwebkit(x86-64) = 5.5.1-3.el6 for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: qt5-qtdeclarative-devel(x86-64) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: qt5-qtbase-devel(x86-64) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: pkgconfig(Qt5Widgets) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: pkgconfig(Qt5Network) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: pkgconfig(Qt5Gui) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: pkgconfig(Qt5Core) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5()(64bit) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Processing Dependency: libQt5WebKit.so.5()(64bit) for package: qt5-qtwebkit-devel-5.5.1-3.el6.x86_64
--> Running transaction check
---> Package qt5-qtbase-devel.x86_64 0:5.5.1-11.el6 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.5.1-11.el6 for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: qt5-qtbase-gui(x86-64) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: qt5-qdoc for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: pkgconfig(gl) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Xml.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5XcbQpa.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Widgets.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Test.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Sql.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5PrintSupport.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5OpenGL.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Network.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Gui.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5DBus.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Core.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
--> Processing Dependency: libQt5Concurrent.so.5()(64bit) for package: qt5-qtbase-devel-5.5.1-11.el6.x86_64
---> Package qt5-qtdeclarative-devel.x86_64 0:5.5.1-2.el6 will be installed
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.5.1-2.el6 for package: qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64
--> Processing Dependency: libQt5QuickWidgets.so.5()(64bit) for package: qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64
--> Processing Dependency: libQt5QuickTest.so.5()(64bit) for package: qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64
--> Processing Dependency: libQt5QuickParticles.so.5()(64bit) for package: qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64
--> Processing Dependency: libQt5Quick.so.5()(64bit) for package: qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64
--> Processing Dependency: libQt5Qml.so.5()(64bit) for package: qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64
---> Package qt5-qtwebkit.x86_64 0:5.5.1-3.el6 will be installed
--> Processing Dependency: libQt5Sensors.so.5()(64bit) for package: qt5-qtwebkit-5.5.1-3.el6.x86_64
--> Processing Dependency: libQt5Positioning.so.5()(64bit) for package: qt5-qtwebkit-5.5.1-3.el6.x86_64
--> Running transaction check
---> Package mesa-libGL-devel.x86_64 0:10.1.2-2.32.amzn1 will be installed
--> Processing Dependency: pkgconfig(libdrm) >= 2.4.24 for package: mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64
--> Processing Dependency: pkgconfig(xdamage) for package: mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64
--> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64
--> Processing Dependency: pkgconfig(xfixes) for package: mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64
---> Package qt5-qdoc.x86_64 0:5.5.1-11.el6 will be installed
---> Package qt5-qtbase.x86_64 0:5.5.1-11.el6 will be installed
--> Processing Dependency: qt5-qtbase-common = 5.5.1-11.el6 for package: qt5-qtbase-5.5.1-11.el6.x86_64
---> Package qt5-qtbase-gui.x86_64 0:5.5.1-11.el6 will be installed
--> Processing Dependency: glx-utils for package: qt5-qtbase-gui-5.5.1-11.el6.x86_64
---> Package qt5-qtdeclarative.x86_64 0:5.5.1-2.el6 will be installed
--> Processing Dependency: libQt5XmlPatterns.so.5()(64bit) for package: qt5-qtdeclarative-5.5.1-2.el6.x86_64
---> Package qt5-qtlocation.x86_64 0:5.5.1-2.el6 will be installed
---> Package qt5-qtsensors.x86_64 0:5.5.1-2.el6 will be installed
--> Running transaction check
---> Package glx-utils.x86_64 0:10.1.2-2.32.amzn1 will be installed
--> Processing Dependency: libGLU.so.1()(64bit) for package: glx-utils-10.1.2-2.32.amzn1.x86_64
---> Package libXdamage-devel.x86_64 0:1.1.3-4.7.amzn1 will be installed
---> Package libXfixes-devel.x86_64 0:5.0.1-2.1.8.amzn1 will be installed
---> Package libXxf86vm-devel.x86_64 0:1.1.3-2.1.9.amzn1 will be installed
---> Package libdrm-devel.x86_64 0:2.4.52-4.12.amzn1 will be installed
---> Package qt5-qtbase-common.noarch 0:5.5.1-11.el6 will be installed
---> Package qt5-qtxmlpatterns.x86_64 0:5.5.1-2.el6 will be installed
--> Running transaction check
---> Package mesa-libGLU.x86_64 0:10.1.2-2.32.amzn1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================================================================================================================================================================
 Package                                                           Arch                                             Version                                                     Repository                                           Size
==========================================================================================================================================================================================================================================
Installing:
 qt5-qtwebkit-devel                                                x86_64                                           5.5.1-3.el6                                                 epel                                                 57 k
Installing for dependencies:
 glx-utils                                                         x86_64                                           10.1.2-2.32.amzn1                                           amzn-main                                            30 k
 libXdamage-devel                                                  x86_64                                           1.1.3-4.7.amzn1                                             amzn-main                                           9.0 k
 libXfixes-devel                                                   x86_64                                           5.0.1-2.1.8.amzn1                                           amzn-main                                            13 k
 libXxf86vm-devel                                                  x86_64                                           1.1.3-2.1.9.amzn1                                           amzn-main                                            18 k
 libdrm-devel                                                      x86_64                                           2.4.52-4.12.amzn1                                           amzn-main                                            95 k
 mesa-libGL-devel                                                  x86_64                                           10.1.2-2.32.amzn1                                           amzn-main                                           490 k
 mesa-libGLU                                                       x86_64                                           10.1.2-2.32.amzn1                                           amzn-main                                           223 k
 qt5-qdoc                                                          x86_64                                           5.5.1-11.el6                                                epel                                                502 k
 qt5-qtbase                                                        x86_64                                           5.5.1-11.el6                                                epel                                                3.4 M
 qt5-qtbase-common                                                 noarch                                           5.5.1-11.el6                                                epel                                                 19 k
 qt5-qtbase-devel                                                  x86_64                                           5.5.1-11.el6                                                epel                                                4.1 M
 qt5-qtbase-gui                                                    x86_64                                           5.5.1-11.el6                                                epel                                                5.3 M
 qt5-qtdeclarative                                                 x86_64                                           5.5.1-2.el6                                                 epel                                                2.7 M
 qt5-qtdeclarative-devel                                           x86_64                                           5.5.1-2.el6                                                 epel                                                771 k
 qt5-qtlocation                                                    x86_64                                           5.5.1-2.el6                                                 epel                                                617 k
 qt5-qtsensors                                                     x86_64                                           5.5.1-2.el6                                                 epel                                                165 k
 qt5-qtwebkit                                                      x86_64                                           5.5.1-3.el6                                                 epel                                                9.3 M
 qt5-qtxmlpatterns                                                 x86_64                                           5.5.1-2.el6                                                 epel                                                1.1 M

Transaction Summary
==========================================================================================================================================================================================================================================
Install  1 Package (+18 Dependent packages)

Total download size: 29 M
Installed size: 104 M
Is this ok [y/d/N]: y
Downloading packages:
(1/19): glx-utils-10.1.2-2.32.amzn1.x86_64.rpm                                                                                                                                                                     |  30 kB     00:00
(2/19): libXdamage-devel-1.1.3-4.7.amzn1.x86_64.rpm                                                                                                                                                                | 9.0 kB     00:00
(3/19): libXfixes-devel-5.0.1-2.1.8.amzn1.x86_64.rpm                                                                                                                                                               |  13 kB     00:00
(4/19): libXxf86vm-devel-1.1.3-2.1.9.amzn1.x86_64.rpm                                                                                                                                                              |  18 kB     00:00
(5/19): libdrm-devel-2.4.52-4.12.amzn1.x86_64.rpm                                                                                                                                                                  |  95 kB     00:00
(6/19): mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64.rpm                                                                                                                                                              | 490 kB     00:00
(7/19): mesa-libGLU-10.1.2-2.32.amzn1.x86_64.rpm                                                                                                                                                                   | 223 kB     00:00
(8/19): qt5-qdoc-5.5.1-11.el6.x86_64.rpm                                                                                                                                                                           | 502 kB     00:00
(9/19): qt5-qtbase-5.5.1-11.el6.x86_64.rpm                                                                                                                                                                         | 3.4 MB     00:00
(10/19): qt5-qtbase-common-5.5.1-11.el6.noarch.rpm                                                                                                                                                                 |  19 kB     00:00
(11/19): qt5-qtbase-devel-5.5.1-11.el6.x86_64.rpm                                                                                                                                                                  | 4.1 MB     00:00
(12/19): qt5-qtbase-gui-5.5.1-11.el6.x86_64.rpm                                                                                                                                                                    | 5.3 MB     00:00
(13/19): qt5-qtdeclarative-5.5.1-2.el6.x86_64.rpm                                                                                                                                                                  | 2.7 MB     00:00
(14/19): qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64.rpm                                                                                                                                                            | 771 kB     00:00
(15/19): qt5-qtlocation-5.5.1-2.el6.x86_64.rpm                                                                                                                                                                     | 617 kB     00:00
(16/19): qt5-qtsensors-5.5.1-2.el6.x86_64.rpm                                                                                                                                                                      | 165 kB     00:00
(17/19): qt5-qtwebkit-5.5.1-3.el6.x86_64.rpm                                                                                                                                                                       | 9.3 MB     00:00
(18/19): qt5-qtwebkit-devel-5.5.1-3.el6.x86_64.rpm                                                                                                                                                                 |  57 kB     00:00
(19/19): qt5-qtxmlpatterns-5.5.1-2.el6.x86_64.rpm                                                                                                                                                                  | 1.1 MB     00:00
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                      11 MB/s |  29 MB  00:00:02
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : qt5-qtbase-common-5.5.1-11.el6.noarch                                                                                                                                                                                 1/19
  Installing : qt5-qtbase-5.5.1-11.el6.x86_64                                                                                                                                                                                        2/19
  Installing : libXfixes-devel-5.0.1-2.1.8.amzn1.x86_64                                                                                                                                                                              3/19
  Installing : libXdamage-devel-1.1.3-4.7.amzn1.x86_64                                                                                                                                                                               4/19
  Installing : qt5-qdoc-5.5.1-11.el6.x86_64                                                                                                                                                                                          5/19
  Installing : qt5-qtxmlpatterns-5.5.1-2.el6.x86_64                                                                                                                                                                                  6/19
  Installing : mesa-libGLU-10.1.2-2.32.amzn1.x86_64                                                                                                                                                                                  7/19
  Installing : glx-utils-10.1.2-2.32.amzn1.x86_64                                                                                                                                                                                    8/19
  Installing : qt5-qtbase-gui-5.5.1-11.el6.x86_64                                                                                                                                                                                    9/19
  Installing : qt5-qtdeclarative-5.5.1-2.el6.x86_64                                                                                                                                                                                 10/19
  Installing : qt5-qtsensors-5.5.1-2.el6.x86_64                                                                                                                                                                                     11/19
  Installing : qt5-qtlocation-5.5.1-2.el6.x86_64                                                                                                                                                                                    12/19
  Installing : qt5-qtwebkit-5.5.1-3.el6.x86_64                                                                                                                                                                                      13/19
  Installing : libXxf86vm-devel-1.1.3-2.1.9.amzn1.x86_64                                                                                                                                                                            14/19
  Installing : libdrm-devel-2.4.52-4.12.amzn1.x86_64                                                                                                                                                                                15/19
  Installing : mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64                                                                                                                                                                            16/19
  Installing : qt5-qtbase-devel-5.5.1-11.el6.x86_64                                                                                                                                                                                 17/19
  Installing : qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64                                                                                                                                                                           18/19
  Installing : qt5-qtwebkit-devel-5.5.1-3.el6.x86_64                                                                                                                                                                                19/19
  Verifying  : qt5-qtdeclarative-5.5.1-2.el6.x86_64                                                                                                                                                                                  1/19
  Verifying  : qt5-qtwebkit-5.5.1-3.el6.x86_64                                                                                                                                                                                       2/19
  Verifying  : qt5-qtdeclarative-devel-5.5.1-2.el6.x86_64                                                                                                                                                                            3/19
  Verifying  : qt5-qdoc-5.5.1-11.el6.x86_64                                                                                                                                                                                          4/19
  Verifying  : qt5-qtsensors-5.5.1-2.el6.x86_64                                                                                                                                                                                      5/19
  Verifying  : qt5-qtxmlpatterns-5.5.1-2.el6.x86_64                                                                                                                                                                                  6/19
  Verifying  : libXdamage-devel-1.1.3-4.7.amzn1.x86_64                                                                                                                                                                               7/19
  Verifying  : qt5-qtbase-devel-5.5.1-11.el6.x86_64                                                                                                                                                                                  8/19
  Verifying  : qt5-qtlocation-5.5.1-2.el6.x86_64                                                                                                                                                                                     9/19
  Verifying  : libdrm-devel-2.4.52-4.12.amzn1.x86_64                                                                                                                                                                                10/19
  Verifying  : glx-utils-10.1.2-2.32.amzn1.x86_64                                                                                                                                                                                   11/19
  Verifying  : qt5-qtbase-5.5.1-11.el6.x86_64                                                                                                                                                                                       12/19
  Verifying  : qt5-qtbase-gui-5.5.1-11.el6.x86_64                                                                                                                                                                                   13/19
  Verifying  : libXxf86vm-devel-1.1.3-2.1.9.amzn1.x86_64                                                                                                                                                                            14/19
  Verifying  : qt5-qtbase-common-5.5.1-11.el6.noarch                                                                                                                                                                                15/19
  Verifying  : mesa-libGL-devel-10.1.2-2.32.amzn1.x86_64                                                                                                                                                                            16/19
  Verifying  : qt5-qtwebkit-devel-5.5.1-3.el6.x86_64                                                                                                                                                                                17/19
  Verifying  : mesa-libGLU-10.1.2-2.32.amzn1.x86_64                                                                                                                                                                                 18/19
  Verifying  : libXfixes-devel-5.0.1-2.1.8.amzn1.x86_64                                                                                                                                                                             19/19

Installed:
  qt5-qtwebkit-devel.x86_64 0:5.5.1-3.el6

Dependency Installed:
  glx-utils.x86_64 0:10.1.2-2.32.amzn1           libXdamage-devel.x86_64 0:1.1.3-4.7.amzn1    libXfixes-devel.x86_64 0:5.0.1-2.1.8.amzn1    libXxf86vm-devel.x86_64 0:1.1.3-2.1.9.amzn1     libdrm-devel.x86_64 0:2.4.52-4.12.amzn1
  mesa-libGL-devel.x86_64 0:10.1.2-2.32.amzn1    mesa-libGLU.x86_64 0:10.1.2-2.32.amzn1       qt5-qdoc.x86_64 0:5.5.1-11.el6                qt5-qtbase.x86_64 0:5.5.1-11.el6                qt5-qtbase-common.noarch 0:5.5.1-11.el6
  qt5-qtbase-devel.x86_64 0:5.5.1-11.el6         qt5-qtbase-gui.x86_64 0:5.5.1-11.el6         qt5-qtdeclarative.x86_64 0:5.5.1-2.el6        qt5-qtdeclarative-devel.x86_64 0:5.5.1-2.el6    qt5-qtlocation.x86_64 0:5.5.1-2.el6
  qt5-qtsensors.x86_64 0:5.5.1-2.el6             qt5-qtwebkit.x86_64 0:5.5.1-3.el6            qt5-qtxmlpatterns.x86_64 0:5.5.1-2.el6

Complete!

できました。