元フリーエンジニアライフ

Ruby on Rails とか MovableType とかAWSやってるフリーランスウェブエンジニアの記録でした。現在は法人成りしてIT社長。

AmazonLinux

Amazon Linux 2015.09 に capybara-webkit gem をインストールしてRubyでブラウジングする

Installing gems capybara-webkit gem gem入れるまでがツラい。→ AmazonLinux 2015.09 に Qt5 WebKit をインストール sudo ln -s /usr/lib64/qt5/bin/qmake /usr/bin/qmake sudo gem install capybara-webkit --no-ri --no-rdoc Building native extensions.…

AmazonLinux 2015.09 に Qt5 WebKit をインストール

まとめ sudo yum install ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/geoclue-0.11.1.1-0.13.20091026git73b6729.el6.x86_64.rpm \ ftp://ftp.riken.jp/Linux/centos/6/os/x86_64/Packages/NetworkManager-glib-0.8.1-99.el6.x86_64.rpm \ ftp:/…

Movable Type for AWS(AMI)(Amazon Linux AMI 2013.09) yumエラー対策

Movable Type for AWS(AMI)は2014/5/7現在、Amazon Linux AMI 2013.09 版がベースです。 そしてこのAMIでは、不整合を防ぐためyumでのperl関連パッケージのアップデートが禁止されています。 /etc/yum.conf # PUT YOUR REPOS HERE OR IN separate files na…